Arhiva | Securitatea aplicatiilor web RSS pentru aceasta categorie
Vulnerabilitate CakePHP <= 1.3.5 / 1.2.8 - Securitatea Informatica

Vulnerabilitate CakePHP <= 1.3.5 / 1.2.8

Data: 20 noiembrie 2010 Descriere: Acest cod exploateaza o vulnerabilitate unserialize() in componenta de securitate a CakePHP. Mai multe detalii aici. Acest exploit functioneaza impotriva oricarei aplicatii dezvoltate pe framework-ul CakePHP care foloseste form-uri POST cu token-uri de securitate si foloseste configuratia Cache default (file-system caching). Este posibila exploatarea si pentru alte tipuri de cache [...]

Citeşte mai mult
Metasploit - Securitatea Informatica

Metasploit

Proiectul Metasploit este un proiect open-source de securitate informatică care oferă informaţii cu privire la vulnerabilităţile de securitate şi ajutor în teste de penetrare. Cel mai bine-cunoscut sub-proiect este framework-ul Metasploit, un instrument pentru dezvoltarea şi executarea exploit-urilor pe o maşină ţintă. Alte sub-proiecte importante sunt baza de date Opcode si arhiva shellcode. Proiectul Metasploit [...]

Citeşte mai mult
Vulnerabilitati PHP – Cross-Site Scripting - Securitatea Informatica

Vulnerabilitati PHP – Cross-Site Scripting

Sfaturi : Puteţi folosii o mulţime de vectori, puteţi încerca o grămadă de metode de a trece peste protecţii, îi puteţi găsii pe internet. Exemplu de bază Cod:. <?php $name=$_GET['name']; print $name; ?> Inputul nu este filtrat, un atacator poate injecta cod JavaScript. Exemplu: http://127.0.0.1/test.php?name=<script>alert(”XSS”)</script> Un popup cu mesajul XSS va fi afişat. Codul JavaScript a [...]

Citeşte mai mult
Vulnerabilitati PHP –  Local File Inclusion - Securitatea Informatica

Vulnerabilitati PHP – Local File Inclusion

Sfaturi : Puteţi folosi trucul cu NULLBYTE şi ? ../ înseamnă un director înapoi Pe serverele Windows puteţi folosi “..\” în loc de “../”. “..\” va devenii “..%5C” (urlencoded). Aceleaşi funcţii care îţi permit să incluzi (include, include_once, require, require_once). Exemplu de bază Cod: <?php $pagina=$_GET['pagina']; include ’/pages/’.$pagina; ?> Acum, nu putem să includem scriptul nostru [...]

Citeşte mai mult
Vulnerabilitate FCKeditor 2.0-2.4.3 - Securitatea Informatica

Vulnerabilitate FCKeditor 2.0-2.4.3

Data: 11 noiembrie 2010 Descriere: Se poate face upload de fisiere cu orice extensie pe server. Pentru versiunea 2.0 – 2.2 codul vulnerabil este in fisierul FCKeditor/editor/filemanager/upload/php/upload.php: $sType = isset( $_GET['Type'] ) ? $_GET['Type'] : ‘File’ ; // Get the allowed and denied extensions arrays. $arAllowed = $Config['AllowedExtensions'][$sType] ; $arDenied = $Config['DeniedExtensions'][$sType] ; asa ca [...]

Citeşte mai mult
Vulnerabilitati PHP –  Local File Disclosure - Securitatea Informatica

Vulnerabilitati PHP – Local File Disclosure

Sfaturi : 1. Prin intermediul acestei vulnerabilităţi putem citii conţinutul variabilelor, nu îl putem include. 2. Câteva funcţii care permit citirea fişierelor: file_get_contents — Citeşte întregul fişier într-un string readfile — Afişează conţinutul unui fişiere file — Citeşte un fişier într-un vector fopen — Deschide un fişier sau un URL highlight_file — Formatează sintaxa unui [...]

Citeşte mai mult
Pagina 2 din 512345
This site is protected by Comment SPAM Wiper. This site is protected by WP-CopyRightPro